Chapter 9 - Managing Files, Folders, and Search Methods
Microsoft® Windows® 2000 Professional makes it easier for users to find and store files and folders, and for administrators to manage file storage and access. By using new tools, such as Group Policy, Indexing Service, and Offline Files, you can prevent users from accessing required system files, enable powerful searches, and prevent network problems from affecting user productivity.
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
For more information about using Group Policy, see “Introduction to Configuration and Management” in this book.

For more information about file and folder security, see “Security” in this book.

For more information about Active Directory™, Group Policy, and IntelliMirror™, and defining and setting configuration standards see the Microsoft® Windows® 2000 Server Resource Kit Distributed Systems Guide and the Microsoft® Windows® 2000 Server Resource Kit Deployment Planning Guide.
Quick Guide to Files, Folders, and Search Methods
Use this quick guide to obtain an overview of what Windows 2000 Professional offers you for managing files, folders, and search methods. Then pinpoint the features you want to use for effectively managing your process. 
Learn new ways to access, view, and store files and folders.
Windows 2000 Professional introduces new features for locating, viewing, and storing files and folders. 

See “What’s New” later in this chapter.
View and access files and folders.
Windows Explorer provides several ways to access and view files and folders on the local computer and network resources. This section describes how to customize and use Group Policy to control user interface options.

See “Working with Files and Folders” later in this chapter.
Set preferences for viewing folders.
Customize and set Group Policy settings to control folder views.

See “Customizing Folders” later in this chapter.
Manage Offline Files and Folders.
Users can cache network files and folders to their hard disk drive for use when network resources are unavailable. Learn how to manage the cache and set Group Policy settings that affect the functionality of Offline Files.

See “Using Offline Files and Folders” later in this chapter.
Understand the new search methods.
The new Active Directory search method (available on a Microsoft® Windows® 2000 Server network) and the powerful Indexing Service make it easier to find files and folders on the network and local drives. Distribute custom Active Directory search files and learn what Group Policy settings are available to control searches.

See “Searching for Files, Folders, and Network Resources” later in this chapter.
Resolve questions about how files and folder searches work.
Find help with problems and answers to common questions about finding files and using the Windows Explorer user interface.

See “Troubleshooting” later in this chapter.
What's New
There are a few significant changes from Microsoft® Windows® 98 and Microsoft® Windows NT® Workstation version 4.0 that affect the way files and folders are stored, viewed, and accessed in the Windows Explorer user interface for Windows 2000 Professional. This section describes these changes.
My Network Places   My Network Places, which was previously named Network Neighborhood, now provides a comprehensive list of all the shared computers, files and folders, printers, and other resources on the network or networks that a computer connects to.
My Computer   My Computer now lists the storage devices available to the computer and provides access to Control Panel. Control Panel has become the central repository for utilities, such as Network and Dial-up Connections and Scheduled Tasks.
My Documents and My Pictures   The contents of My Documents are stored on a per-user basis. A new subfolder in My Documents, called My Pictures, is the default location for storing graphic images, such as digital camera pictures.
Offline Files and Folders   Users can work on files even if the network resource is unavailable. Changes made to files can be automatically synchronized on the server when the network connection is restored.
System Files Hidden by Default   By default, files with system and hidden attributes do not appear in Windows Explorer windows, such as My Computer. This prevents users from inadvertently deleting or modifying required system files.
Indexing Service   You can search for files and folders based on their content, author, size, or other attributes. Indexing Service is available for files stored on the hard disk drive and shared network drives. 
AutoComplete   AutoComplete caches previously typed addresses and file names so that when you begin to type an address or file name, Windows 2000 displays entries similar to what you entered. AutoComplete works throughout the Windows 2000 user interface, including in dialog boxes (such as Run and Map Network Drive) and in Windows Explorer.
Windows 2000 Server Network Advantages
When you use Windows 2000 Professional on a Windows 2000 Server Active Directory network, two new features are available: IntelliMirror and Active Directory. 
With IntelliMirror, users’ documents can be stored, or mirrored, on a centrally managed server. This feature allows users to log on to any computer in the network and obtain access to their documents and files from that computer.
Active Directory allows users to search for network resources by specifying attributes of the object they need, such as a printer capable of printing in color.
For more information about Active Directory and IntelliMirror, see the Distributed Systems Guide and the Deployment Planning Guide.
This chapter describes Group Policy objects that affect working with files, folders, and search methods. Group Policy can be set on the local computer, but it is recommended that Group Policy be administered centrally using a Windows 2000 Server network. For more information about Group Policy, see “Group Policy” in the Distributed Systems Guide.
Working with Files and Folders
This section describes changes to how files are accessed, methods for customizing the Windows Explorer user interface, and policies you can set to control how the interface works.
My Computer
My Computer provides access to local drives, mapped network drives, and Control Panel. System folders, such as Network and Dial-up Connections, Scheduled Tasks, and Printers, are now available through Control Panel.
By using the Address bar, you can quickly access other desktop shortcuts, such as My Network Places, the Recycle Bin, and Internet Explorer.
By default, when you open My Computer, you do not see the Folders Explorer Bar, which displays folders in a hierarchical relationship in a pane on the left side of the user interface.
To display the folders, you can choose Explorer Bar from the View menu and then select Folders. Enabling the Folders option is only in effect until you close My Computer. The next time you open My Computer the folders do not display until you choose the option again. 
You can configure Windows 2000 Professional to show the Explorer Bar every time you open My Computer. To do this, use the following procedure:
To permanently display the Explorer Bar in My Computer
 1.
In My Computer, click the Tools menu, and then click Folder Options.
 2.
Click the File Types tab, and then under Registered file types, click Folder (the extension is N/A).
 3.
Click Advanced.
 4.
Under Actions, click Explore, and then click Set Default.
My Documents and My Pictures
New to Windows NT 4.0 users is the My Documents folder, which is the default location for storing user documents and files. Windows 98 users will notice a new location for the My Documents folder. It is stored with other user profile settings in the Documents and Settings folder. Users who share computers cannot read each other’s documents.
A subfolder of My Documents that is called My Pictures provides a place to store graphics and digital images from sources such as digital cameras. With Web View enabled, you can view images by using thumbnails (see Figure 9.1) or full screen previews, zoom in and out, pan left and right, scroll up and down, and print images.
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Figure 9.1   My Pictures Window Displaying Thumbnails View
If the picture or image is stored on a drive that uses the NTFS file system, you can enter and view text descriptions of picture attributes, such as title, subject description, or category. Additional columns can also be displayed in the folder. 
For more information about changing folder views and using Web view, see “Customizing Folders” later in this chapter.
My Documents is a system folder that cannot be deleted. However, you can rename the desktop shortcut, rename the folder, and redirect the My Documents folder to a network location by using Group Policy. 
Note   If you upgrade to Windows 2000 from a Windows 98 workstation that had redirected the My Documents folder, Windows 2000 Professional redirects My Documents to the same location.
To change the location of the My Documents folder
 1.
Right-click My Documents on the desktop, and then click Properties.
 2.
Under Target folder location, type a destination, or click Find Target to view locations (see Figure 9.2).
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Figure 9.2   Target Tab of the My Documents Properties Dialog Box
Group Policy Settings That Affect My Documents
You can use a Group Policy setting or a combination of Group Policy settings to control the My Documents folder. On a Windows 2000 Server, Group Policy has a special Folder Redirection component. For more information about using Group Policy with Windows 2000 Server, see “Group Policy” and “Introduction to Desktop Management” in the Distributed Systems Guide.
Table 9.1 lists some of the Group Policy settings that affect My Documents and provides a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and with using Microsoft® Management Console (MMC). To make changes to these settings, you must log on as a member of the Administrators group. You can find these Group Policy settings by using the Group Policy MMC snap-in and then following this path: 
Local Computer Policy\User Configuration\Administrative Templates\Desktop 
Table 9.1   Group Policy Settings That Affect My Documents
Group Policy Setting
Description
Hide My Documents icon on desktop
Removes the My Documents icon from the desktop, Windows Explorer, and the Open dialog box.
Prohibit user from changing My Documents path
Disables the Target box in the My Documents Properties dialog box. 
For additional information about Group Policy settings, including a more complete description of each setting, follow the preceding path to the Group Policy setting, right-click the Group Policy setting, click Properties, and then click the Explain tab, or refer to the Group Policy Reference on the Microsoft® Windows® 2000 Resource Kit companion CD.
My Network Places
My Network Places replaces the Network Neighborhood feature that you used in both Windows 98 and Windows NT Workstation 4.0. In the My Network Places window, you can double-click Computers Near Me to quickly access files and folders on other computers in your workgroup or double-click Entire Network to search more widely.
The Add Network Place wizard, also available in My Network Places, guides users through connecting to a shared folder, a Web folder (not a Web site), or an FTP site. Users can specify alternate credentials for automatic access to Web folders and FTP sites. Users can provide friendly names for shortcuts that display in My Network Places. Network resources can be added to the Favorites menu. 
When you open a document on a network resource, a folder shortcut is automatically created in My Network Places.
Note   Mapped network drives do not appear in My Network Places.
Group Policy Settings That Affect My Network Places
You can use a Group Policy setting or a combination of Group Policy settings to control the functioning of the My Network Places folder. For example, with Group Policy on a Windows 2000 Server, an administrator can specify the connections that are displayed in a user’s My Network Places folder. For more information about using Group Policy with Windows 2000 Server, see “Group Policy” and “Introduction to Desktop Management” in the Distributed Systems Guide.
Table 9.2 and Table 9.3 list some of the Group Policy settings that affect My Network Places and provide a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to these settings, you must log on as a member of the Administrators group. You can find the Group Policy settings that Table 9.2 lists by using the Group Policy MMC snap-in and then following this path: 
Local Computer Policy\User Configuration\Administrative Templates\Desktop.
Table 9.2   Group Policy Settings That Affect My Network Places and Desktop Icons
Group Policy Setting
Description
Hide My Network Places icon on desktop
Removes the My Network Places icon from the desktop. This Group Policy setting only affects the desktop icon. It does not prevent users from connecting to the network or browsing for shared computers on the network.
Do not add shares from recently opened documents to My Network Places
Prevents a connection from being saved if it was established by opening files on remote shares.
Hide all icons on Desktop
Removes all icons and shortcuts, including My Network Places, from the desktop.
You can find the Group Policy settings that Table 9.3 lists by using the Group Policy MMC snap-in and then following this path: 
User Configuration\Administrative Templates\Windows Components\Windows Explorer.
Table 9.3   Group Policy Settings That Affect My Network Places 
Group Policy Setting
Description
No “Computers Near Me” in My Network Places
Removes computers in the user’s workgroup  from lists of network resources.
No “Entire Network” in My Network Places
Removes all computers outside the user’s workgroup from lists of network resources.
Remove “Map Network Drive” and “Disconnect Network Drive”
Prevents using My Network Places to connect to other computers or to close existing connections.
For additional information about Group Policy settings, including a more complete description of each setting, follow the preceding paths to the Group Policy setting, right-click the Group Policy setting, click Properties, and then click the Explain tab, or refer to the Group Policy Reference on the Microsoft® Windows® 2000 Resource Kit companion CD.
Windows Explorer
In Windows 2000 Professional, Windows Explorer is located in the Accessories folder. Using Windows Explorer, you can easily add, remove, reorder, and size columns by right-clicking any column heading. 
By default, the My Documents folder is selected when Windows Explorer opens. You can change the focus to My Computer.
To open Windows Explorer with My Computer selected
 1.
Click Start, point to Programs, point to Accessories, right-click Windows Explorer, and then click Properties.
 2.
On the Shortcut tab, type the following text in the Target box:
%SystemRoot%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
To restore Windows Explorer to the default My Documents view
 1.
Click Start, point to Programs, point to Accessories, right-click Windows Explorer, and then click Properties.
 2.
On the Shortcut tab, type the following text in the Target box:
%SystemRoot%\explorer.exe /e,::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Command Line Switches for Windows Explorer
You can control the functionality of Windows Explorer by using the command-line switches listed in Table 9.4.
Use the following syntax:
EXPLORER.EXE [/n][/e][,/root,<object>][[,/select],<sub object>]
Table 9.4   Command-Line Switches to Control Windows Explorer
Command-Line Switch
Description
/n
Opens a new window in single-paned (My Computer) view for each item selected, even if the new window duplicates a window that is already open.
/e
Uses Windows Explorer view. Windows Explorer view is similar to File Manager in Windows version 3.x. Note that the default view is Open view.
/root,<object>
Specifies the root level of the specified view. The default is to use the normal namespace root (the desktop). Whatever is specified is the root for the display.
/select,<sub object>
Specifies the folder to receive the initial focus. If /select is used, the parent folder is opened and the specified object is selected.
The following examples illustrate how you can use command-line switches to modify the way you view folders and objects in Windows Explorer:
To view objects on \\<server name> only:
explorer /e,/root,\\<server name>
To view the C:\Windows folder and select Calc.exe:
explorer /select,c:\windows\calc.exe
Group Policy Settings That Affect Windows Explorer
You can use a Group Policy setting or a combination of Group Policy settings to control the functioning of Windows Explorer. For more information about using Group Policy with Windows 2000 Server, see “Group Policy” and “Introduction to Desktop Management” in the Distributed Systems Guide.
Table 9.5 lists some of the Group Policy settings that affect Windows Explorer and provides a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to these settings, you must log on as a member of the Administrators group. You can find these Group Policy settings by using the Group Policy MMC snap-in and then following this path: 
Local Computer Policy\User Configuration\Administrative Templates\Windows Components\Windows Explorer
Table 9.5   Group Policy Settings That Affect Windows Explorer
Group Policy Setting
Description
Enable Classic Shell
Disables Active Desktop, Web View, Thumbnails view, and single-click mouse option. User interface looks and acts like Windows NT 4.0.
Remove File menu from Windows Explorer
Hides the File menu in My Computer and Windows Explorer. Does not disable other methods of performing the same tasks.
Remove “Map Network Drive” and “Disconnect Network Drive”
Prevents you from using Windows Explorer and My Network Places to connect to or disconnect from other computers.
Remove Search button from Windows Explorer
Hides the Search button in Windows Explorer but shows it in Internet Explorer and on the Start menu.
Disable Windows Explorer’s default context menu
Prevents shortcut menus from appearing when you right-click items in Windows Explorer.
Hides the Manage item on the Windows Explorer context menu
Prevents the Compmgmt.msc file from running when you choose the Manage command in Windows Explorer or shortcut menus in My Computer.
Hide these specified drives in My Computer
Removes icons that represent selected disk drives from My Computer and Windows Explorer.
Prevent access to drives from My Computer
Prevents viewing content on selected drives in My Computer, Windows Explorer, and My Network Places. Disables the Run command, the Map Network Drive dialog box, and the Dir command at the command prompt.
Disable UI to change menu animation setting
Disables the option that animates the movement of windows, menus, and lists.
Disable UI to change keyboard navigation indicator setting
Disables the Hide keyboard navigation indicators until I use the Alt key check box on the Effects tab of Display in Control Panel.
Disable DFS tab
Removes the DFS tab from the Properties dialog box when you right-click a folder in Windows Explorer or in other programs that use the Windows Explorer browser, such as My Computer. As a result, users cannot use this tab to view or change the properties of the Distributed file system shares that are available from their computer.
No “Computers Near Me” in My Network Places
Prevents computers in the user’s workgroup or domain from appearing in My Network Places or Windows Explorer.
No “Entire Network” in My Network Places
Prevents any computer that is outside the user’s workgroup from appearing as network resources in My Network Places or Windows Explorer.
For additional information about Group Policy settings, including a more complete description of each setting, right-click the Group Policy setting, click Properties, and then click the Explain tab, or refer to the Group Policy Reference on the Microsoft® Windows® 2000 Resource Kit companion CD.
Customizing Folders
Windows 2000 Professional offers new options for using Windows Explorer to view folders and new ways to set your viewing preferences. Two new ways to customize folder views in Windows Explorer are as follows: choosing Folder Options from the Tools menu or using the Customize This Folder wizard. 
Setting Folder Options
All the options for customizing folder views and preferences are found in Folder Options on the Tools menu. Folder Options has four tabs: General, View, File Types, and Offline Files.
You use the General tab to configure Active Desktop and Web view. You can also configure whether new windows open as you browse folders and whether you single-click or double-click to select items. 
The View tab is the primary location for setting folder options. The options that are available on the View tab of the Folder Options dialog box are shown in Figure 9.3.
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Figure 9.3   The View Tab of the Folder Options Dialog Box
For more information about setting options on the View tab and the File Types tab, see Windows 2000 Professional Help. 
For more information about using the Offline Files tab, see “Using Offline Files and Folders” later in this chapter.
Using the Customize This Folder Wizard
The Customize This Folder wizard allows you to choose and edit folder templates, preview and set the background picture, define colors for the file name and background, and add a comment for the folder that can be viewed when an HTML template is used to display folder contents. The wizard creates a hidden Desktop.ini file and a hidden folder containing the folder settings.
Using the Customize This Folder Wizard
 1.
In My Computer or Windows Explorer, click the folder you want to customize.
 2.
Click the View menu, and then click Customize This Folder.
Using Web View with the Wizard
Enable Web view on the General tab of the Folder Options dialog box. With Web view enabled, use the Customize This Folder wizard to set the folder’s background to any image file format, such as .bmp, .jpg, .gif, .tif, .dib, .png, .art, and .xif files. The background image is seen by anyone who accesses the folder. 
Web view works by applying HTML templates to folder views. Some of the default folder templates are stored in %WinDir%\web and are hidden files. For example, the Folder.htt file is the template that is applied to most folders. Be careful not to delete or move these files.
Note   In Windows 98, you could enable Web content for individual folders. In Windows 2000, Web content is either enabled or disabled for all folders.
Understanding Saved Views and Browsing Folders
In Windows 2000 Professional, the view you use is not always permanently saved in Windows Explorer. You can control whether the views you use are saved permanently or temporarily by using the Remember each folder’s view settings check box on the View tab of the Folder Options dialog box (see figure 9.3). 
By default the Remember each folder’s view settings option is enabled. When you choose to leave this setting enabled, the following happens:

The changes you make to a folder’s view is automatically saved when you close the folder.

The view you use to view one folder is not applied to other folders.

When you open a folder, it opens in the view you used when you last viewed it.
When you clear the check box for Remember each folder’s view settings, the following happens:

When you start Windows Explorer, the first folder you view displays in the folder’s saved view. Windows Explorer holds that view in temporary memory and applies it to all the folders that you visit while Windows Explorer remains open unless you manually alter the view.

As you browse to other folders (after the initial folder is opened), the saved view for each folder is ignored, and when you quit Windows Explorer, the folder view that you have been using to view multiple folders is deleted from temporary memory.

The next time you open Windows Explorer, once again, it is the saved view of the first folder you open that determines how you view multiple folders.
Setting All Folders to the Same View
Some users want to have all their Windows Explorer folders set to the same view. In Windows 2000 Professional, the default setting is that any change made to a folder’s view is automatically saved when you close the folder and is not applied to other folders. However, you can set all folders to the same view by using the Folder Options command as described in the following procedure.
To set all folders to the same view
 1.
In My Computer or Windows Explorer, set the view to your preference.
 2.
On the Tools menu, click Folder Options.
 3.
In the Folder Options dialog box, click the View tab.
 4.
Under Folder Views, click Like Current Folder.
Important   The Remember each folder’s view settings check box on the View tab of the Folder Options dialog box (see Figure 9.3) affects how the view settings of individual folders are applied and saved. For more information about the impact of clearing this check box, see "Understanding Saved Views and Browsing Folders" earlier in this chapter.
Group Policy Settings That Affect Folders
You can use Group Policy settings to control how folders are used.
Table 9.6 lists some of the Group Policy settings that affect folders and provides a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to these settings, you must log on as a member of the Administrators group. You can find these Group Policy settings by using the Group Policy MMC snap-in and then following this path: 
User Configuration\Administrative Templates\Windows Components\Windows Explorer.
Table 9.6   Group Policy Settings That Affect Folders
Group Policy Setting
Description
Remove the Folder Options menu item from the Tools menu
Disables the Folder Options command on the Tools menu. Properties on folders cannot be set.
Enable Classic Shell
Disables Active Desktop, Web View, Thumbnails view, and single-click mouse action. User interface looks and acts like Windows NT 4.0.
For additional information about Group Policy settings, including a more complete description of each setting, follow the preceding path to the Group Policy setting, right-click the Group Policy setting, click Properties, and then click the Explain tab, or refer to the Group Policy Reference on the Microsoft® Windows® 2000 Resource Kit companion CD.
Using Offline Files and Folders
Offline Files provides access to network files and folders from a local disk when the network is unavailable. This feature is particularly useful when access to information is critical, when network connections are unstable and nonpermanent, and when you are using mobile computers. This section discusses how Offline Files works and how to manage computers using Offline Files.
For specific information about using Offline Files with mobile computers, see “Mobile Computing” in this book. 
Overview of Offline Files and Folders
Any shared file or folder on a Microsoft network can be made available offline. You can make files available from any computer that supports server message block (SMB)–-based File and Printer Sharing, including Microsoft® Windows® 95, Windows 98, and Windows NT 4.0. Offline Files is not available on Novell NetWare networks or when Windows 2000 is running Terminal Services.
Files specified for offline use are stored, or cached, in a database on the hard disk drive of the local computer. If the network resource becomes unavailable, notification appears in the status area. Changes made to the file while offline are saved locally and then synchronized when the network resource is available.
Offline files and information about them are stored in a database in a hidden system folder (%systemroot%\CSC). The database emulates the network resource while it is offline so that files are accessed as though the network resource is still available.
The Offline Files Folder is created when files are requested offline and provides a view of the files stored in the database. 
Caution   If the network resource is online, renaming files in the Offline Files Folder takes effect immediately on the network resource.
To access Offline Files configuration options
 1.
In My Computer or Windows Explorer, click a folder.
 2.
On the Tools menu, click Folder Options.
 3.
Click the Offline Files tab.
Note   If there is already an Offline Files shortcut on your desktop, you can skip the following procedure and access the Offline Files Folder by double-clicking the desktop shortcut to Offline Files.
To access the Offline Files Folder
 1.
In My Computer of Windows Explorer, click a folder.
 2.
On the Tools menu, click Folder Options.
 3.
Click the Offline Files tab.
 4.
Click View Files.
Making Files Available Offline
Files are cached to the computer that requests them in one of two ways: automatic caching or manual caching. Automatic caching occurs when a specific file in a folder has been opened, but only if the network server indicates that the contents of the share should be automatically cached. Automatically cached files are marked as Temporarily Available Offline in the Offline Files Folder because they can be removed from the cache as the cache fills up. There is no guarantee that an automatically cached file will be available when offline. Automatic caching does not cache all the files in a folder.
Files are manually cached when a computer specifically requests, or pins, a particular file or folder on the network to be available offline. Files and folders are pinned by selecting the file or folder and clicking Make Available Offline on the File menu. Manually cached files are marked as Always available offline in the Offline Files Folder. The icon representing the file or folder updates to depict its offline status.
In Windows 2000 Professional, when a folder is shared, Manual Caching for Documents setting is enabled by default. To change the setting so that documents are automatically cached, right-click the folder, click Sharing, and then click Caching. In the Setting box, click Automatic Caching for Documents. You can also choose to disable caching.
Note   You can also manually pin files and folders that have been configured for automatic caching.
By default, the following files types cannot be cached: 
   *.SLM; *.MDB; *.LDB; *.MDW; *.MDE; *.PST; *.DB?
You can override the default settings by using the Files not cached Group Policy setting. Any file types you specify in the Group Policy setting override the default files types not usually cached. For example, if you specify that only *.txt files cannot be cached, all other file types become available for caching. .
The default cache size for automatically cached offline files is 10 percent of the total disk space of the hard disk drive. You can change the default (specify a value between 0 and 100 percent) on the Offline Files tab of the Folder Options dialog box (accessed by clicking Folder Options on the Tools menu). This setting does not affect the cache for manually cached files. You can store up to 2 gigabytes (GB) of manually cached files per computer if you have that much space available. 
More About the Offline Files Database
The database containing information about Offline Files resides in the hidden system folder, or directory, called %systemroot%\CSC. The name CSC refers to client side caching. The CSC directory contains all offline files requested by any user on the computer. 
Files in the CSC directory are not encrypted, nor is encryption preserved, but file permissions and system permissions on the file are preserved. Therefore, a Microsoft® Word document created by Peter Tysver, given a password, and saved to a share on which only he has Full user rights, cannot be opened from the CSC directory by Renee Smith, because she has neither the share rights to open the file nor the password required to open the file in Microsoft Word.
To open or view the files in the CSC directory, you must log on as a member of the Administrators group. Because file encryption is not preserved, it is possible to log on as an administrator and to open files and view their content from the CSC directory by using a program such as Notepad. Users who share computers need to be aware that sensitive information can be viewed by anyone who is a member of the Administrators group. 
Note   On a FAT file system or a FAT file system converted to NTFS, users might be able to read information that is cached in the %systemroot%\CSC directory. This includes offline files requested by another user on the same computer.
It is very important not to move or delete files directly from the CSC directory. For more information about moving the cache folder and deleting files from the cache, see “Managing Offline Files” later in this chapter.
Reconnecting to the Network Resource
When a network share becomes available after being offline (for example, a server goes offline and is then brought back online, or a mobile computer is disconnected from the network and then reconnected), the network share is automatically available when three conditions are met:

No offline files from that network share are open on the user’s computer.

No offline files from that network share have changes that need to be synchronized.

The network connection is not considered a slow link.
When all these conditions are satisfied and a user opens a file on the network share, the user is automatically working online on that network share. Any changes that a user makes is saved to the file on the network share and to the file that is cached in the Offline Files Folder. When any of these conditions are not satisfied and a user opens a file on the network share, the user is still working offline even though the network share is available. Any changes the user makes are saved only to the offline version of the file.
For more information about reconnecting over slow links or with mobile computers, see “Mobile Computing” in this book.
Synchronizing Files and Folders
It is important to understand how synchronization works between the locally cached version and the network resource version of a file. There are several ways to initiate synchronization, and, depending on the method you choose and the options you’ve enabled, either a full or quick synchronization of the files occurs.
When full synchronization occurs, the most current version of every cached network file is cached to the local drive. A quick synchronization is faster, but might not provide the most current version of every network file that has been made available offline. However, a quick synchronization does ensure that a complete version of every file is available. 
There are several options that control how files are synchronized when the network resource becomes available. You can choose to synchronize:

Automatically at logon.

Automatically at logoff.

Manually at any time.

When the computer is idle for a specified amount of time.

Automatically at specified times.
To configure synchronization
 1.
Click Start, point to Programs, point to Accessories, and then click Synchronize.
 2.
Click Setup.
 3.
Use the Logon/Logoff, On Idle, and Scheduled tabs to configure options.
Note   Synchronization works only for the user who is currently logged on. 
You can also start synchronization from Windows Explorer by clicking the Tools menu and then clicking Synchronize. 
In order for synchronization to work, the network resources must be online or available for reconnection. Depending on how the synchronization is executed, offline changes might or might not be sent to the network resource and new versions of cached files might or might not be downloaded. In cases where a quick or partial synchronization occurs, data is copied from the network only to ensure availability while offline. When a full synchronization occurs, newer versions of files on the network are located and cached. Table 9.7 describes what kind of synchronization occurs when each method is used. 
Table 9.7   Description of Synchronization Options and How Files are Cached
Synchronization commands and options
Send offline changes to the network resource?
Receive cached files from the network resource?
Automatically synchronize the selected items when I log on to my computer
Yes
No
Synchronize all offline files before logging off is enabled
Yes
Fully
Synchronize all offline files before logging off is disabled
No
Partially
Synchronize the selected items while my computer is idle
Yes
Partially
Scheduled
Yes
Fully
Clicking Synchronize from the Start menu or on the Tools menu
Yes
Fully
Clicking Synchronize on the File menu
Yes
Fully
Clicking Make Available Offline on the File menu
No
Partially
From the Offline Files icon in the Status area of the task bar
Yes
No
If the network resource version of a file and the locally cached version of the file are different, you can choose one of the following options in the Resolve file conflicts dialog box. 

Keep both versions. Saves the version on my computer to the network as <filename>(username vX).doc, where filename is the name of the file, username is my user name, and X is the version number.

Keep only the version on my computer. Replaces the network version.

Keep only the network version. Replaces the version on my computer.
You are given the option to view each individual file. The date and time the files were saved is provided.
Using Offline Files on Mobile Computers
Offline files are particularly useful for mobile computer users. For more information about using offline files on mobile computers, such as synchronizing with a slow link and preventing synchronization when running on battery power, see “Mobile Computing” in this book.
Managing Offline Files
There are several different options you can use to delete files and folders no longer needed for offline use. It is important to understand how, where, and when to delete files, so that no changes are lost and files needed offline are still available.
Deleting Files and Folders
It is very important that nothing is deleted or moved directly from the %systemroot%\CSC folder. When you need to remove all the files in the folder, see “Deleting All the Offline Files and Folders in the Cache” later in this chapter.
Remember, if you are working with files in the Offline Files Folder when the network resource is online, you are working directly on the network computer. When you rename or modify files from this location, the changes are immediately saved both in the Offline Files Folder and on the network resource.
There are two methods for safely removing offline files from the cache without affecting network files or folders. You can choose to delete files from the Offline Files Folder or click the Delete Files button on the Offline Files tab of the Folder Options dialog box (accessed by clicking Folder Options on the Tools menu).
Deleting Files from the Offline Files Folder
You can open the Offline Files Folder and delete files directly from the list of offline files. This allows you to delete individual files regardless of where they are located on the network or which folder they are contained in. When you delete a file this way, the file is removed from the cache regardless of whether it was manually cached (pinned) or whether it was automatically cached. 
Note   Deleting files and folders from the cache does not delete the network copy of the file or folder. 
If an offline folder is manually cached and you delete any or all offline files in the folder, the folder remains pinned and all files in the folder are cached the next time a full synchronization occurs.
To delete files from the cache using the Offline Files Folder
 1.
Click a folder, and on the Tools menu, click Folder Options.
 2.
On the Offline Files tab, click View Files.
 3.
Click the file you want to delete and on the File menu, click Delete.
Using the Delete Files Function
You can delete all files on a network share using the Delete Files button on the Offline Files tab of the Folder Options dialog box (accessed by clicking Folder Options on the Tools menu). This method allows you to delete every file in a network share and to distinguish between automatically cached files (temporarily available offline) and manually cached files (always available offline). 
If you delete manually cached folders this way, the folders and the files in them are no longer pinned. To make those files or folders available offline again, you need to pin the files or folders. When you delete automatically cached files this way, you only need to open the files to make them temporarily available offline.
Note   Deleting files and folders from the cache does not delete the network copy of the file or folder. 
To delete files from the cache on a network share
 1.
Click a shared network folder and then on the Tools menu, click Folder Options.
 2.
On the Offline Files tab, click Delete Files.
 3.
In the Confirm File Delete dialog box, select the shared folders containing the offline files you want to delete.
 4.
Click Delete only the temporary offline versions if you want to delete files that have been automatically cached. Click Delete both the temporary offline versions and the versions that are always available offline if you want to delete files that have been automatically cached and files that have been manually cached (pinned).
Note   Files are also deleted from the cache whenever an offline file is deleted through any usual user path, such as Windows Explorer, My Computer, the Run dialog box, or the Command Prompt. When users verify that they want to delete a file, the file is removed from the cache. This is not an effective way to clean up the cache because it also deletes files in the shared network folder.
Deleting All the Offline Files and Folders in the Cache
You can delete all the offline files stored in the %systemroot%\CSC folder by using a process known as reinitializing the cache. This method deletes all offline files from the Offline Files Folder and resets the Offline Files database. If any files in the cache have changed and have not been synchronized with the network versions, the changes are lost when the cache is reinitialized. You must restart the computer after the cache is reinitialized. 
To reinitialize the Offline Files cache
 1.
Click a folder, and then on the Tools menu, click Folder Options.
 2.
Click the Offline Files tab.
 3.
Press CTRL+SHIFT, and then click Delete Files.
 4.
Restart the computer.
Caution   You cannot undo the effects of reinitialization. After the cache is reinitialized all offline files are permanently removed from the computer.
Moving the Cache
The only way to safely move the hidden system folder (%systemroot%\CSC) is by using the Offline Files Cache Mover (Cachemov.exe) tool available on the Windows 2000 Resource Kit companion CD. You can move the cache database to another location on a fixed disk only.
For more information about using the Offline Files Cache Mover tool, see Windows 2000 Resource Kit Tools Help on the Windows 2000 Resource Kit companion CD.
Policy Settings That Affect Offline Files
You can use a Group Policy setting or a combination of Group Policy settings to control the functionality of the Offline Files feature. For more information about using Group Policy with Windows 2000 Server, see “Group Policy” and “Introduction to Desktop Management” in the Distributed Systems Guide.
Table 9.8 lists some of the Group Policy settings that affect Offline Files and provides a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to these settings, you must log on as a member of the Administrators group. You can find these Group Policy settings by using the Group Policy MMC snap-in and then following this path: 
Local Computer Policy\User Configuration\Administrative Templates\Network\Offline Files.
Note   These Group Policy settings appear in the User Configuration folders. If Group Policy settings are also configured in the Computer Configuration folders, the setting in Computer Configuration takes precedence over the setting in User Configuration.
Table 9.8   Group Policy Settings in User Configuration That Affect Offline Files
Group Policy Setting
Description
Disable user configuration of Offline Files
Removes the Offline Files tab from the Folder Options dialog box. It also removes the Settings command from the Offline Files shortcut menu and disables the Settings button in the Offline Files Status dialog box. As a result, users cannot view or change the options on the Offline Files tab or in the Offline Files dialog box.
Synchronize all offline files before logging off
Determines whether offline files are fully synchronized when users log off. Disables the option on the Offline Files tab in the Folder Options dialog box.
Action on server disconnect
Determines whether network files remain available if the computer is suddenly disconnected from the server hosting the files. Also disables the When a network connection is lost option on the Offline Files tab in the Folder Options dialog box.
Nondefault server disconnect actions
Determines how computers respond when they are disconnected from particular offline file servers. This Group Policy setting overrides the default response, a user-specified response, and the response specified in the Action on server disconnect Group Policy setting.
Disable “Make Available Offline”
Removes the Make Available Offline command from the user interface.
Prevent use of Offline Files folder
Disables the View Files button on the Offline Files tab in the Folder Options dialog box.
Disable reminder balloons
Hides the reminder balloons that would appear above the Offline Files icon in the status area.
Reminder balloon frequency
Determines how often reminder balloons appear.
Initial reminder balloon lifetime
Determines how long the first reminder balloon for a network status change is displayed.
Reminder balloon lifetime
Determines how long updated reminder balloons are displayed.
Event logging level
Determines which events the Offline Files feature records in the event log.
All the Group Policy settings that are available in the User Configuration folder are also available in the Computer Configuration folder. The Group Policy settings listed in Table 9.9 are only used as Computer Configuration settings. You can find the Computer Configuration Group Policy settings by using the Group Policy snap-in and then following this path:
Local Computer Policy\Computer Configuration\Administrative Templates\Network\Offline Files. 
Note   If a Group Policy setting is configured in both locations, the Computer Configuration setting takes precedence.
Table 9.9   Group Policy Settings in Computer Configuration That Affect Offline Files
Group Policy Setting
Description
Default cache size
Limits the percentage of the computer’s disk space that can be used to store automatically cached offline files.
Files not cached
Lets you exclude certain types of files from automatic and manual caching for offline use. Warning: See “Making Files Available Offline” earlier in this chapter.
Administratively assigned offline files
Lists network files and folders that are always available for offline use. Makes the specified files and folders available offline to users of the computer.
At logoff, delete local copy of user’s offline files
Deletes local copies of the user’s offline files when the user logs off. This Group Policy setting specifies that automatically and manually cached offline files are retained only while the user is logged on to the computer. When the user logs off, the system deletes all local copies of offline files.
For additional information about Group Policy settings, including a more complete description of each setting, right-click the Group Policy setting, click Properties, and then click the Explain tab, or refer to the Group Policy Reference on the Microsoft® Windows® 2000 Resource Kit companion CD.
Searching for Files, Folders, and Network Resources
Windows 2000 Professional makes it easy to search for files, folders, and resources using the new Windows Explorer user interface, the Search Assistant, and Indexing Service.
Navigating through Windows Explorer in Windows 2000 Professional is similar to using a Web browser. Forward and Back buttons, a History folder, an Address bar, custom views, and the Search Assistant have been added to all windows accessed through My Computer, My Network Places, My Documents, the Search command on the Start menu, and in Windows Explorer windows.
When you use Windows 2000 Professional on a Windows 2000 Server Active Directory domain, you can search the directory by specifying attributes for the resource you want. For example, you can search for printers capable of printing double-sided pages. For more information about using Active Directory, see “Using Active Directory to Search for Network Resources” later in this chapter.
Finding Files and Folders
Windows 2000 offers a number of ways to find files or folders. Each method provides access to the Search Assistant, History folder, and Indexing Service on the local computer.
You can search for files and folders in the following ways:

On the Start menu, point to Search and then click For Files or Folders, On the Internet, For People, or in an Active Directory domain, For Printers.

On the Start menu, point to Programs, point to Accessories, and then click Windows Explorer.

On the desktop, double-click My Documents, My Computer, or My Network Places.
Group Policy Setting That Affects Searching for Files and Folders
You can use a Group Policy setting to control how you search for files and folders. Table 9.10 lists a Group Policy setting that affects how you search for files and folders and provides a brief description of it. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to this setting, you must log on as a member of the Administrators group. You can find this Group Policy setting by using the Group Policy MMC snap-in and then following this path: 
Local Computer Policy\User Configuration\Administrative Templates\Start Menu & Taskbar.
Table 9.10   Group Policy Setting That Affects Searching for Files and Folders
Group Policy Setting
Description
Remove Search menu from Start menu
Removes the Search menu from the Start menu and shortcut menus, and disables the use of the F3 and Application key+F keystrokes.
Saving and Opening Files
Among the new features of Windows 2000 Professional are the new Save As and Open dialog boxes. 
In the left pane, shortcuts to the History folder, the Desktop, My Documents, My Computer, and My Network Places provide easy access to these locations. You can customize the appearance of the right pane by choosing to view Large Icons, Small Icons, List, Details, or Thumbnails.
In addition, Windows 2000 provides a list of recently used files in the File name box. When you begin typing in the File name box, files with names similar to the characters you type appear. You can choose from the list or continue typing to create a new file name.
Figure 9.4 illustrates the new features of the Open and Save As dialog boxes.
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Figure 9.4   New Features of the Open and Save As Dialog Boxes
Group Policy Settings That Affect Saving and Opening Files
You can use Group Policy settings to control how you save and open files. Table 9.11 lists Group Policy settings that affect how you save and open files and provides a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to these settings, you must log on as a member of the Administrators group. You can find these Group Policy settings by using the Group Policy MMC snap-in and then following this path:
User Configuration\Administrative Templates\Windows Components\Windows Explorer.
Table 9.11   Group Policy Settings That Affect Saving and Opening Files
Group Policy Setting
Description
Hide these specified drives in My Computer
Removes the icons representing selected disk drives from My Computer. Also, the drive letters representing the selected drives do not appear in the standard Open dialog box.
Prevent access to drives from My Computer
Prevents users from using My Computer to gain access to the content of selected drives.
Using the History Folder
The Windows 2000 Professional History folder integrates Web links and network shares, so that no matter from where you view the History folder, you have access to everywhere you’ve been. You can choose to view the History folder by using the following filters: By Date, By Site, By Most Visited, or By Order Visited Today.
The History view, which you selected from the toolbar in Windows Explorer, tracks the history of all Web sites and now tracks the history of all documents you've opened. You can sort by location, date used, or search the history list itself, using option buttons.
Group Policy Settings That Affect the History Folder
Table 9.12 lists Group Policy settings that affect the History folder and provides a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to these settings, you must log on as a member of the Administrators group. You can find these Group Policy settings by using the Group Policy MMC snap-in and then following this path:
Local Computer Policy\User Configuration\Administrative Templates\Start Menu & Taskbar.
Table 9.12   Group Policy Settings That Affect the History Folder
Group Policy Setting
Description
Do not keep history of recently opened documents
Prevents shortcuts to documents from appearing on the Documents submenu (accessed by clicking Start and then pointing to Documents).
Clear history of recently opened documents on exit
Deletes the contents of the Documents submenu on the Start menu when the user logs off.
Connecting to Network Shares
Windows 2000 Professional allows you to map drives directly to shared subfolders on the network. For example, in previous versions of Windows, you mapped drives to \\servername\sharename. In Windows 2000, you can map drives to \\servername\sharename\subsharenname.
You can use the Add Network Place wizard to connect to frequently accessed network resources. Mapped network drives do not appear in My Network Places. To view mapped drives, use My Computer or the Address bar as shown in the Figure 9.5.
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Figure 9.5   Mapped Drive as Viewed on the Address Bar in My Network Places
Group Policy Setting That Affects My Network Places
Table 9.13 lists a Group Policy setting that affects the History folder and provides a brief description of it. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to this setting, you must log on as a member of the Administrators group. You can find this Group Policy setting by using the Group Policy MMC snap-in and then following this path:
Local Computer Policy\User Configuration\Administrative Templates\Desktop.
Table 9.13   Group Policy Setting That Affects My Network Places
Group Policy Setting
Description
Do not add shares of recently opened documents to My Network Places
Prevents the system from adding a connection to shared folders accessed through My Network Places.
You can find the Group Policy settings listed in Table 9.14 by using the Group Policy MMC snap-in and then following this path:
User Configuration\Administrative Templates\Windows Components\Windows Explorer.
Table 9.14   Group Policy Settings That Affect My Network Places
Group Policy Setting
Description
Remove “Map Network Drive” and “Disconnect Network Drive”
Prevents users from using Windows Explorer or My Network Places to connect to other computers or to close existing connections.
No “Entire Network” in My Network Places
Removes all computers outside the user’s workgroup from lists of network resources in Windows Explorer and My Network Places.
No “Computers Near Me” in My Network Places
Removes computers in the user’s workgroup and domain from lists of network resources in Windows Explorer and My Network Places.
Using Indexing Service
Indexing Service is a Windows 2000 service that extracts information from a set of documents and organizes it in a way that makes it quick and easy to access that information through the Windows 2000 Search Assistant, the Indexing Service query form, or a Web browser. This information can include text from within a document (its contents), and the characteristics and parameters of the document (its properties), such as the author’s name. After the index is created, you can search, or query the index for documents that contain key words, phrases, or properties. For example, you can run a query for all documents containing the word “product” or you can run a query for all Microsoft Office documents written by a specific author. Indexing Service returns a list of all documents that meet the search criteria. 
Indexing Service can index the following types of documents in several languages:

HTML 

Text 

Microsoft Office 95 and later 

Internet mail and news 

Any other document for which a document filter is available 
Indexing Service automatically stores all the index information in the System or the Web catalogs. 
To enable Indexing Service on a local computer
 1.
Click Start, point to Search, and then click For Files or Folders.
 2.
In the left pane of the Search Results dialog box (see Figure 9.6), click the Search Options link, and then click the Indexing Service link.
 3.
Click Yes, enable Indexing Service and run when my computer is idle.
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Figure 9.6   Search Options Dialog Box
Indexing Service is designed to run continuously and requires little maintenance. After it is set up, all operations are automatic, including index creation, index updating, and crash recovery if there is a power failure. 
For more information about Indexing Service, see “Administering Indexing Service” in the Microsoft Management Console (MMC) Help file. Other topics in the MMC Help file explain how the Indexing Service works and how to conduct searches. 
Group Policy Setting That Affects Indexing Service
Table 9.15 lists a Group Policy setting that controls users’ access to Indexing Service and provides a brief description it. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to this setting, you must log on as a member of the Administrators group. You can find this Group Policy setting by using the Group Policy MMC snap-in and then following this path:
User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins
Table 9.15   Group Policy Setting That Affects Indexing Service
Group Policy Setting
Description
Indexing Service
Permits or prohibits users from gaining access to the Indexing Service snap-in.
Using Active Directory to Search for Network Resources
When Windows 2000 Professional is connected to a Windows 2000 Server using Active Directory, you can search the directory for resources such as computers, printers, people, and shared folders, as long as the resource is published in the Active Directory.
To help users locate resources quickly, you can create custom Active Directory searches and distribute query directory search (*.qds) files to workgroups or organizational units.
Active Directory contains objects and each object is assigned specific attributes. For example, if a printer is capable of printing double-sided pages, the Active Directory administrator can specify that attribute for the printer in the Active Directory. When a user searches for printers capable of printing double-sided, the search returns all printers with that attribute. If the administrator chooses not to give the printer that attribute, even if it is capable of that function, the printer wouldn’t be found by searching only for that attribute.
For more information about Active Directory, see the Windows 2000 Server Resource Kit.
Important   To search using Active Directory, the computer must be part of a Windows 2000 Server Active Directory domain.
Searching for Printers
To search for printers in an Active Directory domain, click Start, point to Search, and then click For Printers. If For Printers does not appear on the Search menu, your computer is not connected to an Active Directory domain.
Searching for People
In an Active Directory domain, click Start, point to Search, and click For People to start an Active Directory search. You can also specify to use an Internet search service in the Look in box. If you are not in an Active Directory domain, Active Directory does not appear as an option in the Look in box.
Searching for Computers
When you use Windows 2000 Professional in an Active Directory domain, you can search for computers two ways: using NetBIOS or using Active Directory. It is important to understand the difference between the two methods.
In previous versions of Windows, any time you specify a search for computers, the computer executes a NetBIOS search. If the computer you search for is logged on to the network, you can connect to it and view its shared folders. Figure 9.7 illustrates the results of a NetBIOS search and the available shares on the computer that was found.
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Figure 9.7   NetBIOS Search Results Displaying Available Shares
To search for computers using NetBIOS
 1.
Click Start, point to Search, and then click For Files or Folders.
 2.
In the left pane, click the Computers link.
In an Active Directory network search, computers in the directory are represented by objects. You can locate an object even when it is disconnected from the network. Therefore, when you double-click the icon representing a computer found using an Active Directory search, only the properties for that computer are displayed, as shown in the Figure 9.8. The actual computer and its available shares are not available from an Active Directory search. To access shares in an Active Directory domain, the shares must be published and you must know the name of the share. 
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Figure 9.8   Active Directory Search Results Displaying the Computer’s Properties
To search for computers using Active Directory
 1.
In My Network Places, double-click Entire Network.
 2.
Do one of the following:

If Web View is enabled, click the entire contents link, and then double-click Directory.

If Web View is not enabled, double-click Directory.
 3.
Right-click the object representing an Active Directory domain, and then click Find.
 4.
In the Find box, click Computers. 
Note   You might need to specify an object in the In box.
Searching for Shared Files and Folders
To access files and folders in an Active Directory domain, the Active Directory administrator must first publish them. Folders that are shared but not published do not appear in the Search Results window. If you search for a computer by using Active Directory, you can not view or access any shared folders residing on that computer. You must execute a NetBIOS search to view shares. For more information about NetBIOS searches, see “Searching for Computers” earlier in this chapter. 
You can use the Search Assistant in Active Directory to locate shared folders, but you must specify the exact folder name. You cannot browse a list of shared folders. To find a shared folder in Active Directory, open the Search Assistant, and in the Find box, click Shared Folders. Then, in the Named box on the Shared Folders tab, type the shared folder name.
Group Policy Settings That Affect Active Directory
Table 9.16 lists Group Policy settings that affect Active Directory searches and provides a brief description of each. Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to these settings, you must log on as a member of the Administrators group. You can find these Group Policy settings by using the Group Policy MMC snap-in and then following this path:
Local Computer Policy\User Configuration\Administrative Templates \Desktop\Active Directory.
Table 9.16   Group Policy Settings That Affect Active Directory
Group Policy Setting
Description
Maximum size of Active Directory searches
Specifies the maximum number of objects returned on an Active Directory search. Use to protect the network and the domain controller from the effect of expansive searches. 
Enable filter in Find dialog box
Displays a filter bar above the results of an Active Directory search, so additional filters can be applied. 
Hide Active Directory Folder
Removes the Active Directory folder from My Network Places. 
Preventing Access to System Files
Windows 2000 Professional provides new ways to help prevent users from deleting or modifying operating system and hidden files. By default, hidden files and folders and system files do not display in Windows Explorer windows or search results views.
To view system files, clear the Hide protected operating system files (Recommended) check box on the View tab of the Folder Options dialog box (accessed by clicking Folder Options on the Tools menu). 
To view hidden files and folders, select the Show hidden files and folders option on the View tab of the Folder Options dialog box (accessed by clicking Folder Options on the Tools menu).
Group Policy Setting That Prevents Access to System Files
Table 9.17 lists a Group Policy setting that prevents access to system files and provides a brief description of it. You can use this Group Policy setting to prevent users from changing the setting that hides system and hidden files and folders.
Before you change a Group Policy setting, you should be familiar with using Group Policy and MMC snap-ins. To make changes to this setting, you must log on as a member of the Administrators group. You can find this Group Policy setting by using the Group Policy MMC snap-in and then following this path:
User Configuration\Administrative Templates\Windows Components\Windows Explorer.
Table 9.17   Group Policy Setting That Prevents Access to System Files
Group Policy Setting
Description
Remove the Folder Options menu item from the Tools menu
Removes the Folder Options command from all Windows Explorer menus and removes the Folder Options icon from Control Panel.
Troubleshooting
The following topics are frequently asked questions about working with files, folders, and search methods. For more general information about troubleshooting in Windows 2000 Professional, see “Troubleshooting Tools and Strategies”in this book.
Why is nothing listed in the relevance column in my search results window?
The Relevance column is used only when Indexing Service is enabled and you search for a word, phrase, or other content. The relevance of an item represents a ranking that indicates how closely the content in the file matches the text you searched for. In Figure 9.9, the Relevance column of the Search Results window is blank, indicating that Indexing Service is not enabled or that a content search was not performed.
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Figure 9.9   The Relevance Column in the Search Results Window
Why can’t I view system files, such as my Swap file?
By default, Windows 2000 hides files with attributes of System and Hidden. You can enable the Show hidden files and folders setting on the View tab in the Folder Options dialog box to view hidden files. To see files with both the Hidden and System attributes, you must also disable the Hide protected operating system files (Recommended) option on the View tab in the Folder Options dialog box. To access the Folder Options dialog box, click Folder Options on the Tools menu.
Why can’t I see shared folders on the network?
You are probably using an Active Directory search. In an Active Directory search for computers, you can only see the properties of the computer, not the available shares. Execute a NetBIOS search instead. See “Using Active Directory to Search for Network Resources” earlier in this chapter.
How do I recover deleted Administrative Tools shortcuts?
Unlike previous versions of Windows, you can delete shortcuts to programs in the Administrative Tools folder in Control Panel.
If you delete a shortcut, you can restore it from the Recycle Bin. If the shortcut is no longer in Recycle Bin, you can add it to the Administrative Tools folder using the information in Table 9.18.
To add a shortcut to Administrative Tools
 1.
Open Administrative Tools in Control Panel.
 2.
On the File menu, point to New, and then click Shortcut.
 3.
Use Table 9.18 to find the value to type in the Type the location of the item box.
 4.
Click Next.
 5.
Use Table 9.18 to find the proper name of the tool and type it in the Type a name for this shortcut box. 
 6.
Click Finish.
 7.
Follow the steps in the procedure that follows Table 9.18.
Table 9.18   Name, Description, and Location of Administrative Tools Files in Windows 2000 Professional
Tool Name
Tool Description
Tool File Name and Location
Component Services
Configures and manages Component Services applications.
%SystemRoot%\system32\com\comexp.msc
Computer Management
Starts and stops services, manages disks, and provides access to other system tools to manage local and remote computers.
%SystemRoot%\system32\compmgmt.msc /s
Data Sources (ODBC)
Adds, removes, and configures Open Database Connectivity (ODBC) data sources and drivers.
%SystemRoot%\system32\odbcad32.exe
Event Viewer
Displays and allows configuration of monitoring and troubleshooting messages from Windows and other programs.
%SystemRoot%\system32\eventvwr.msc /s
Local Security Policy
Displays and allows configuration of security levels assigned to a Group Policy object or local computer Group Policy setting.
%SystemRoot%\system32\secpol.msc /s
Performance
Displays graphs of system performance and configures data logs and alerts.
%SystemRoot%\system32\perfmon.msc /s
Component Services
Configures and manages Component Services applications.
%SystemRoot%\system32\com\comexp.msc
Services
Start, stop, pause, or resume services on remote and local computers, and configure startup and recovery options.
%SystemRoot%\system32\services.msc /s
Telnet Server Administration
View and modify telnet server settings and connections.
%SystemRoot%\system32\tlntadmn.exe
The following procedure changes the Start in location so the program can find necessary associated files. The Start in location is the same for all tools described in Table 9.18.
To Specify the Start in location
 1.
Click the shortcut, and then on the File menu, click Properties.
 2.
In the Start in box on the Shortcut tab, type the following:
%HomeDrive%%HomePath%
Additional Resources

For more information about the new location and name of a feature from a previous version of Windows, see Windows 2000 Professional Help. 

For more information about using the registry, see the Technical Reference to the Windows 2000 Registry on the Windows 2000 Resource Kit companion CD.
